ลงทะเบียน
ใกล้กัน ช่วยให้คุณแชร์เรื่องราวต่างๆ กับผู้คนมากมาย

แก้ปัญหา Yum Update ไม่ยอมอัพเดต CentOS7

แก้ปัญหา Yum Update ไม่ยอมอัพเดต CentOS7

โพสต์ใน: ระบบ / - โดย - Nov 16, 2019

แก้ปัญหา CentOS 7 ไม่ยอมให้อัพเดตด้วย Yum Update สาเหตุเกิดจากระบบเก่าจึงไม่สามารถอัพเดต Package ที่ออกมาใหม่ได้

- You could try using --skip-broken to work around the problem
- You could try running: rpm -Va --nofiles --nodigest

 

วิธีแก้ที่ 1 เป็นวิธีทีง่ายที่สุดให้ Yum ข้าม Package ที่มีปัญหาด้วยคำสั่งนี้

yum -y update --skip-broken

 

วิธีแก้ที่ 2 คือให้ข้ามแพ็คเกจที่ Error โดยระบุชื่อที่มีปัญหา: Yum Update --exclude=ตามด้วยชื่อ Package

yum update --exclude=phpMyAdmin-5* --exclude=php-phpmyadmin-sql-parser5* --exclude=php-symfony4*  --exclude=php-twig2*  --exclude==php-williamdes-mariadb-mysql-kbs*

สรุป: แนะนำให้ใช้วิธีที่สองจะข้ามเฉพาะ Package ที่มีปัญหา (Package ที่เกี่ยวข้องจะได้รับการอัพเดต แตกต่างจากวิธีแรกจะข้ามทุก Package ที่เกี่ยวข้อง) 

 

 

ตัวอย่าง Error ด้านล่างเป็นแพ็คเกจที่ต้องใช้ PHP v7 หรือสูงกว่าแต่ปัจจุบันยังเป็น PHP v5

ปัญหาที่ตามมา: หากอัพเกรตเป็น PHP v7 เว็บที่เขียนด้วย PHP v5 จะพังทันทีดังนั้นข้ามแพ็คเกจคือแนวทางแก้ปัญหาที่ดีที่สุ ดในตอนนี้

 


=> Error: Package: php-twig2-2.12.1-1.el7.remi.noarch (remi)
Requires: php(language) >= 7.0
..

=> Error: Package: php-symfony4-common-4.1.13-1.el7.remi.noarch (remi)
Requires: php(language) >= 7.1.3
Removing: php-common-5.6.40-13.el7.remi.x86_64 (@remi-php56)
php(language) = 5.6.40
..

=> Error: Package: php-phpmyadmin-sql-parser5-5.0.0-1.el7.remi.noarch (remi)
Requires: php(language) >= 7.1
..

=> Error: Package: phpMyAdmin-5.0.0~alpha1-2.el7.remi.noarch (remi-test)
Requires: php(language) >= 7.1.3
..

 

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 

ขอบคุณแหล่งข้อมูล:
https://www.cyberciti.biz/faq/centos-rhel-fedora-yum-missing-dependency/

 

LINUX

User not write anything about he.
Captcha Challenge
ลองรูปภาพใหม่
Type in the verification code above

ลองอ่านดูน่าสนใจ: