ลงทะเบียน
ใกล้กัน ช่วยให้คุณแชร์เรื่องราวต่างๆ กับผู้คนมากมาย

ปัีญหา Browser Internet Explorer รุ่นเก่าไม่รองรับเว็บฯ

ปัีญหา Browser Internet Explorer รุ่นเก่าไม่รองรับเว็บฯ

โพสต์ใน: เว็บไซต์ / - โดย - Jan 31, 2020

ปัญหา Browser: Internet Explorer รุ่นเก่าไม่รองรับการเขียนเว็บในปัจจุบัน 
แนะนำให้เปลี่ยนไปใช้ Google Chrome หรือ Firefox จะครอบคลุมทั้ง PC และ Mobile 

 

อย่างไรก็ตามยังมีกลุ่มผู้ใช้ในสำนักงานที่ต้องใช้ Internet Explorer ตามระบบ Windows XP

คนเขียนเว็บที่ต้องรองรับฐานลูกค้ากลุ่มนี้ จำเป็นต้องเขียน Script เพื่อแยกเป็น 2 ชุดคำสั่งให้รองรับการทำงานไม่ผิดเพี้ยน โดยฟังค์ชั่นด้านล่างจะส่งค่า True หากตรวจพบเป็น Browser Internet Explorer

function isMSIE()
{
var ua = window.navigator.userAgent;
console.log(ua);
var msie = ua.indexOf("MSIE");
var msie11 = ua.indexOf(".NET4");
var isIE = 0;

if(msie > 0) {
isIE = 1;
}
else if(msie11 > 0) {
isIE = 1;
}
else if(ua == "Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; AS; rv:11.0) like Gecko") {
isIE = 1;
}
return isIE;
}

 

เขียนเว็บไซต์

User not write anything about he.
Captcha Challenge
ลองรูปภาพใหม่
Type in the verification code above

It will be interesting: